Fusion density issues

Discussion in 'Machinery Matters' started by James, Jul 12, 2019.

  1. James

    James Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    2,442
    Location:
    Comber, Co Down
    So fusion 3 has had a new density block replaced by McHale because it wasn't charging the chamber properly. Recently the pressure began dropping quickly and not charging tothe set value of around 170. Putting the box into manual made no difference. Mechanic came out first thing he did was unscrew the density setting knob and screw it back in. This cured it and it has worked well for a while. I've since done this again. But I'm still not happy with the bales and the fact that neither the dealer nor McHale seem to know the reason why. Anyone had anything similar happen?
     
  2. diesel power

    diesel power Well-Known Member

    Joined:
    May 27, 2012
    Messages:
    13,545
    Location:
    Laois
    Blown out O-ring or rings in the block?. Happened a friends Fusion. If your still in bother let me know and I'll ask him about it.
     
  3. johndeere6920s

    johndeere6920s Well-Known Member

    Joined:
    Jun 21, 2013
    Messages:
    13,395
    Location:
    south west ireland
    The copper washer or the accumulator? If you put her in manual it should go to 210 bar
     
  4. JohnDeere6210r

    JohnDeere6210r Member

    Joined:
    Sep 30, 2017
    Messages:
    6
    Copper Washer, Accumulator, Door Ram Seals would be the first things id be checking. What made them decide to change the block?
     
  5. James

    James Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    2,442
    Location:
    Comber, Co Down
    He decided that the block must have had a crack internally.
     
  6. wdah

    wdah Well-Known Member

    Joined:
    Dec 2, 2011
    Messages:
    2,469
    Location:
    tyrone
    might be similar set up, but not linked not looking to hijack.

    I have a 5500 here for demo to try before I buy. what way does the pressure set up work compared to when u have it set and when it should aut start net, currently about 3/4 way into red when net starts and back at 160-170 on pressure when net finished, is this right, when closing door it stops just at start of red
     
  7. Mf 7715

    Mf 7715 Well-Known Member

    Joined:
    Sep 29, 2017
    Messages:
    1,083
    That sounds about right. But with heavy 24' rows pressure will rise quick after buzzer goes off so I try and stop as soon as buzzer goes off.
     
  8. john415

    john415 Well-Known Member

    Joined:
    Dec 11, 2011
    Messages:
    4,077
    Location:
    wexford
    What tractor have you it on.mine went haywire when the oil in the jd got hot wrapping ring slows and door looses pressure.onto fendt no problem
     
  9. 086lavey

    086lavey Well-Known Member

    Joined:
    Oct 16, 2010
    Messages:
    1,519
    Location:
    Mayo,Ireland
    What do John Deere have to say about that ?
     
  10. James

    James Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    2,442
    Location:
    Comber, Co Down
    Mf 7618
     
  11. john415

    john415 Well-Known Member

    Joined:
    Dec 11, 2011
    Messages:
    4,077
    Location:
    wexford
    Reckon it's something internal.i don't think I'd buy another jd without warrenty this one has clocked more hours going back to the garage.
     

Share This Page