Hitachi EX60-5 excavator Electrical start trouble

Countyhouse

New Member
A few days ago our Hitachi EX60-5 would not switch off or rev up after being working for 30 minutes. I pulled the mechanical stop button and that stopped it. When I went to start it again it half turned but did not start. Some of the lights on the dash dimmed sometimes and other times they did not light at all. It had two new batteries fitted about 6 months ago, but as it was standing for a while I charged both batteries and tried again. Same thing happened, wouldn’t rev or stop. Electrician suggested replacing the stop and start relays underneath the solenoid. Replaced them but no joy. I also replaced the ignition switch as it used to stick at times but that didn’t help. Brought batteries back to where I bought them and they fully charged them and said they are fine. The charging light does not come on when the machine is running, which indicated that the alternator is charging. Earth is good, any ideas what could be wrong?

Could it be the Alternator running down the batteries?
 

headcase

Very Senior Member
A few days ago our Hitachi EX60-5 would not switch off or rev up after being working for 30 minutes. I pulled the mechanical stop button and that stopped it. When I went to start it again it half turned but did not start. Some of the lights on the dash dimmed sometimes and other times they did not light at all. It had two new batteries fitted about 6 months ago, but as it was standing for a while I charged both batteries and tried again. Same thing happened, wouldn’t rev or stop. Electrician suggested replacing the stop and start relays underneath the solenoid. Replaced them but no joy. I also replaced the ignition switch as it used to stick at times but that didn’t help. Brought batteries back to where I bought them and they fully charged them and said they are fine. The charging light does not come on when the machine is running, which indicated that the alternator is charging. Earth is good, any ideas what could be wrong?

Could it be the Alternator running down the batteries?
Get multi meter out
Batteries should be around 12.7 full charge and go up to 14.4 machine running
Dont take the alternator light going out as gospel
 

Win

Well-Known Member
A few days ago our Hitachi EX60-5 would not switch off or rev up after being working for 30 minutes. I pulled the mechanical stop button and that stopped it. When I went to start it again it half turned but did not start. Some of the lights on the dash dimmed sometimes and other times they did not light at all. It had two new batteries fitted about 6 months ago, but as it was standing for a while I charged both batteries and tried again. Same thing happened, wouldn’t rev or stop. Electrician suggested replacing the stop and start relays underneath the solenoid. Replaced them but no joy. I also replaced the ignition switch as it used to stick at times but that didn’t help. Brought batteries back to where I bought them and they fully charged them and said they are fine. The charging light does not come on when the machine is running, which indicated that the alternator is charging. Earth is good, any ideas what could be wrong?

Could it be the Alternator running down the batteries?
Usually lack of electrical power would cause the engine to stop, what is the set up electric motor doing throttle and stop or a separate stop solenoid?
 
Top